Jump to content

Please help identify this issue with my fish??


Chadders
 Share

Recommended Posts

Noticed this today on my White Mountain Minnow. No other fish appear affected. I don't have a quarantine tank or hang on tank so it's in a bag at the mo. I thought it might be a fungus so bought some API Pimafix. I've added one dose to the tank so far. Also wondered if it was Ich? Any Ideas?? it's a pinky white blob / spot.  

9AE7E823-BDC2-4743-95E7-C87BB808CA25_1_201_a.jpeg.62ff116b632b75931fa96a9b50592575.jpeg

F1457D10-9B75-4D49-AFCF-D520BD6EB56C.jpeg

Link to comment
Share on other sites

10 hours ago, Colu said:

I would put him back  in the tank treat with aquarium salt 1table spoon for 3gallons  if you have live plants it will affect them

Thanks for the reply is that US or UK gallons because they are different I normally work in litres 🙂 would I add the salt to the tank directly or is it best added to a water change then added it slowly to the tank? I have pure sea salt would that be ok there's no additives in it. Also what can I expect to see happen to the plants? 

I've put the fish back with his tank mates he seems to be acting normal and it's not got any worse. 

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...