Jump to content

Search the Community

Showing results for tags 'sulfur smell'.

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • General
    • Introductions & Greetings
    • General Discussion
    • Photos, Videos & Journals
    • Plants, Algaes, and Fertilizers
    • Fish Breeding
    • Diseases
    • Aquarium Co-Op's Local Announcements
    • Forum Announcements
  • Off Topic
    • Off Topic General

Blogs

  • Daniel's Fishroom Blog

Calendars

There are no results to display.

Product Groups

There are no results to display.


Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


About Me

Found 2 results

  1. A couple of days ago I got my 55 gallon setup with Fluval Stratum and also got some "Natural Creek Stone" I got from Home Depot, thought it would be a money saver, look neat against the black background and substrate. I did rinse and clean the rocks. However, after 2 days have gone by I am noticing a sulfur smell. I've never used Fluval Stratum before but I also don't think that's where the smell is coming from. I have a feeling it is coming from the rocks. Someone had suggested I boil/bake the rocks but I do have a concern about explosions and not sure that would necessarily fix the problem--but then again I don't know. The tank is not stocked with any fish and won't be until likely after the holidays. Other concerns about the rocks, because hindsight is 20/20, is whether or not the rocks will alter the water chemistry, hardness, etc over time. I plan on doing a large school of neon tetras and possibly other fish that prefer similar water parameters. Haven't completely decided on everything. My gut instinct is to remove the rocks and find a new purpose for them, after all once plants are taking over the tank I probably won't see much of the bottom anyway. I don't know what type of rock these are other than they're natural creek stone and not cement. I guess the first question is to rule out the possibility that the Fluval Stratum would be the cause of the smell? Second is the likelihood of these rocks being an issue. I'm not opposed to removing the rocks but wouldn't mind not having to remove them either. edit: The water parameters after 24 hours after filling were: pH 6.6, GH 72 ppm, KG 36 ppm, Ammonia 1 ppm, Nitrite 0 ppm and Nitrate >0 but less than 5 ppm. I rechecked the water and nothing has changed (that I can measure).
  2. Hello, I have had a 50 Gallon tank setup for over a year now. The last two times i have gravel vacuumed the tank the water coming out of the tank smells of sulfur(edit: this has been probably over a month that the smell has been there when gravel vaccing). What causes this and is it anything i should be worried about? Mulm is present around the root plants ( i dont vacuum these areas) Substrate is black gravel. (tanks does have 17 small mystery snails but all are alive and moving so i dont think its dead snail) ammonia 0 nitrite 0 nitrate 10~ ( running CO2 and have to dose ferts to keep nitrates readable) ph 7.2 sponge filter is the filter and sponge was cleaned 3 weeks ago.
×
×
  • Create New...