Jump to content

Search the Community

Showing results for tags 'plant defencies'.

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • General
    • Community Resources
    • Introductions & Greetings
    • General Discussion
    • Photos, Videos & Journals
    • Plants, Algae, and Fertilizers
    • Fish Breeding
    • Diseases
    • Experiments
    • Aquarium Co-Op's Local Announcements
    • Aquarium Co-Op Events
    • Forum Announcements
  • Off Topic
    • Off Topic General

Blogs

  • Daniel's Fishroom Blog
  • Music
  • Music for Fish

Calendars

There are no results to display.

Product Groups

There are no results to display.


Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


About Me

Found 2 results

  1. Is this a deficiency? I dose with easy green but split it between 2 doses a week in a 60 gallon tank. I run an AquaSky 2.0 and no CO2. To me they are the only plants out of crypts, anubias, crinum, Madagascar lace, vals, and apongoneton that looks this beat up, aside from some GSA If it’s a deficiency what kind and how do I fix it. Or are they just old leaves that need to get pulled? Thanks
  2. In a lot of my responses to posts you may see me link these two videos. These were two videos that helped me the MOST when figuring out what was wrong with my planted tanks, and some of the most frequent questions asked. Do you have any videos that you found EXTREMLEY helpful? Link them below: I link them so often I made a playlist with them:
×
×
  • Create New...