Jump to content

Search the Community

Showing results for tags 'betta imbellis'.

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • General
    • Community Resources
    • Introductions & Greetings
    • General Discussion
    • Photos, Videos & Journals
    • Plants, Algae, and Fertilizers
    • Fish Breeding
    • Diseases
    • Experiments
    • Aquarium Co-Op's Local Announcements
    • Aquarium Co-Op Events
    • Forum Announcements
  • Off Topic
    • Off Topic General

Blogs

  • Daniel's Fishroom Blog
  • Music
  • Music for Fish

Calendars

There are no results to display.

Product Groups

There are no results to display.


Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


About Me

Found 2 results

  1. Hey everyone! I have a single betta, D'artagnan, in a 10 gallon tank with a bubble filter. There's a 50 watt heater that keeps the temp at 78F. I also have some java moss and water sprite. I bought the water sprite a couple weeks ago and they aren't doing so well. I have a plant light for them and it's on about 8 hours a day. I just bought some fertilizer, iron, and root tabs for them. Hopefully that will help my water sprite. Does anyone have any tips on how to get rid of the white fuzzy algae? (please note, right now I cannot get shrimp or snails) Also, enjoy a pic of D'artagnan (he doesn't have popeye, that's just a smudge on the glass) Thanks, Artemis
  2. I’m suspecting it might have some imbellis but I’m not positive
×
×
  • Create New...